
HyperCube Updates 

Version 11.52 (05/01/15) 

1. Mac and PC:  Principal Components of a cube window is now an additional option 
in menu Utilities -> Apply Transformation -> Cube Transform.  Note:  This capability 
is still available in menu Image -> Convert Image -> Principal Components with more 
generality (e.g., can be performed on a cube file). 

2. PC: Bug fix:  The dialog appearing when Loading SDF files allowed multiple 
outputs of cube and LAS files using the orientation/directions permutations.  This 
would create invalid LAS files.  Multiple permutations are no longer allowed when 
creating a cube or LAS file.  (The SDF file format is not available in the Mac 
version). 

3. Mac and PC: Bug fix:  When loading a LASF file all of the point returns were 
processed regardless of selecting a specific  return number.  This was a recently 
introduced bug.  Loading a LASF file using the point cloud option was not affected by 
this bug. 

Version 11.51 (2/10/15) 

1. Mac and PC: Bug fix:  Menu Utilities -> Apply Transformation -> Cube 
Transform, introduced in version 11.5, had a serious bug that would crash for certain 
size cubes with a large number of bands (~500).   Fixed. 

Version 11.5 (01/31/15) 

1. Mac and PC:  The ability to load LASF 1.4 files and the extraction of the 
waveforms has been added.  This includes all point cloud viewing. 

2. Mac and PC:  The Dem and Ortho output images of menu Applications -> Stereo -> 
Compilation can be saved as a complete (elevation and intensity) LASF 1.2 file via 
menu File -> Save As -> LASF and saving the Dem image. 

3. Mac and PC:  Menu Utilities -> Apply Transformation -> Cube Transform allows 
several types of frequency domain transformations of image cubes. 

4. Mac and PC:  New option to use the file's position in the list as the return number 
when merging LAS files (menu Utilities -> Merge LASF Files).  This allows them to 
be  shown separately in the point cloud viewer.  This is limited to 5 LASF files. 

5. Mac and PC:  Better omega and phi  rotation effect in the point cloud viewer. 



6. Mac and PC: Bug fix:  Added better logic to detect and strip superfluous values in 
the first line of an ASCII LASF file. 

7. Mac and PC: Bug fix:  A failure to generate a profile line on ASCII LASF overview 
windows was corrected. 

8. Mac and PC: Bug fix:  When duplicating a point cloud viewer image the individual 
return numbers were not propagated.  All returns were set to 1. 

9. Mac: Bug fix:  Small LASF files (less than 1MB) would display an erroneous error 
message and not load. 

Version 11.4 (10/01/14) 

1. Mac and PC:  The ability to load, display and process LAS 1.3 format files has been 
added.  This includes both internal and external wdp file versions .  Previously, 
limited to the LAS 1.2  specification.   

2. Mac and PC:  The waveform data in LAS 1.3 files can be extracted and saved as a 
cube.  The cube can then be processed using menu Functions -> Classify methods. 

3. PC: You can now save Riegl SDF full wave as LAS 1.3 (functions as an SDF -> 
LAS 1.3 converter). 

4. Mac and PC:  More types of colorization added to Point Cloud Options. 

5. Mac and PC:  A specific return number may be specified when viewing a point 
cloud. 

6.  Mac and PC:  The sample "Lidar.las" file included in the webpage has been 
replaced with one containing up to 5 returns. 

7.  Mac and PC:  A new sample file, "Lidar 1.3.las", was added to the webpage.  It 
contains LAS 1.3 waveform data. 

8. PC: Bug fix:  If menu Edit -> Options -> Detailed Messages was checked and menu 
Functions -> Plot -> Spectra (dynamic) enabled then an erroneous filter was applied to 
the displayed spectral signature.  Fixed. 

9. PC: Bug fix:  When pasting (cmd v)  the clipboard contents into a scrolled window 
the PC version would sometimes crash.  This is a very old bug recently discovered. 

Version 11.3 (07/01/14) 



1. Mac and PC:   An anaglyphic 3D view has been added to the Point Cloud viewing 
capability.  Using red/cyan glasses the point cloud may be viewed and manipulated in 
stereo.  This is in addition to the mono view window.  You can select the amount of 
parallax to be applied. 

2. Mac and PC:   The elevation colorization option in Point Cloud Options has been 
improved and allows the percentage of color tint to be added to the elevation. 

2. Mac and PC:   Menu Image -> Attach -> Remove/Modify Data now permits the 
underlying attached data of an image to be changed from implicit to explicit (see 
description in HyperCube.pdf, section Attach/Remove Data).  

Version 11.2 (05/9/14) 

1. PC:   The Riegl (www.riegl.com) proprietary dll (32 bit and 64 bit) needed to 
process Lidar full wave form (FWF) sample data files (SDF) in now included in the 
HyperCube.zip download folder.  The dll should be placed in the same folder as the 
executable.  This functionality only applies to the Windows PC version.   An SDF 
example data set, Duncan Knob.zip, has been added to the web page along with a 
description in the Quick_Start.pdf document. 

2. Mac: Bug fix:  Menu Functions -> Histogram gave an erroneous result  and 
sometimes crashed when performing a histogram of the  point cloud view window.  

3. Mac and PC: Bug fix: The amount of memory allocated for point cloud viewing 
was greatly oversized and could cause a crash of the PC 32 bit version. 

Version 11.1 (03/10/14) 

1. Mac and PC:  A second type of image profiling (menu Functions -> Plot -> Profile) 
is displayed when the source image window is a point cloud view.  The profile 
represents a planar slice with user defined width through the point cloud and is 
displayed as a scatter plot of elevation verses distance along the profile line. 

2. PC:   The ability to load and process Riegl (www.riegl.com) full wave form (FWF) 
sample data files (SDF) has been added (menu File -> Open -> SDF).  This 
functionality is only available in the PC version.  However, it requires the  use of 
Riegl’s proprietary dll which, presently, can only be obtained from Riegl. 

3. Mac and PC: Bug fix: The point cloud viewer (a subset of menu File-> Open -> 
LASF ) did not return to its initial load state after choosing Reset in the  Point Cloud 
Viewer dialog. 

Version 11.00 (01/15/14) 



1. Mac:  The Power PC version of HyperCube is no longer maintained with updates.  
It will remain at version 10.80. 

2. Mac and PC:  A major addition for exploiting Lidar LASF data was added to allow 
the data to be viewed as a point cloud.  The position, direction and type of projection 
of the data points can be interactively modified.  This capability is an extension of the 
Load LASF function.  A Lidar data set has been added to the HyperCube website for 
experimentation. 

3. Mac and PC:   Menu Functions > Image Arithmetic did not always convert a color 
image to gray (function gray()).  This has been fixed. 

4. Mac and PC:   Corrected the ENVI header wavelength extraction that is part of the 
Hyperion (HDF) data files. 

Version 10.90 (09/04/13) 

1. Mac:  The Power PC version of HyperCube is no longer maintained with updates.  
It will remain at version 10.80. 

2. Mac and PC:  The capability to create an exact output scale has been added to menu 
File ->  Load LASF dialog. 

3. Mac and PC:   An anaglyphic image creation option was added to menu File -> 
Open as… LASF and Open as… ASCII Lidar. 

4. Mac and PC:   An anaglyphic image creation was also added to menu Applications 
> Stereo > Mate… . 

5. Mac and PC:  The angle and heading of the scan line now appear at the bottom of a 
plot created via menu Functions -> Plot -> Profile. 

Version 10.80 (09/04/12) 

1. Mac and PC:  The ability to load TIFF files containing LZW compression has been 
added.  This includes 8 bit gray, 8 bit true color, 16 bit gray, 16 bit component color 
and 32 float images.  It is not possible to save TIFF files with LZW compression. 

2. Mac and PC: Bug fix: It’s now possible to enable/disable a contiguous interval of 
spectral bands in menu Windows -> Show Band -> List ->  Options. 

3. PC: Bug fix:  Menu Edit -> Options -> Color Selector… did not properly sync 
sliders and patch color.  Only a bug in PC version. 



4. Mac and PC: The statistics region selected via menu Functions -> Classify -> 
Options -> Stats Region: Class map was not used correctly – gave erroneous message: 
“Not enough points”. 

5. Mac and PC: The precision of the output ASCII text when saving a spectral list has 
been changed from 4 to 6 decimal places for the reflectance values.  

6. Mac and PC: National Geospatial Agency (NGA) compliance added to GeoTIFF 
images. 

7. Mac and PC: Bug fix: Menu Functions -> Classify method Mahalanobis did not 
propagate statistical region names into the final class map.  The color of the statistical 
region was correctly maintained. 

8. Mac Intel: Bug fix:  Menu Applications -> Radiance -> Plot BB Curve… crashed.  
This was a bug introduced in version 10.70. 

9. Mac and PC: Bug fix: An erroneous error message was given in menu Edit -> 
Options -> Image to Ref Coords… when switching between UTM and Geographic 
coordinates. 

10. Mac PPC: Bug fix:  The Mac Power PC version did not write the CRC field of 
PNG files in the correct byte order.  This caused some commercial applications to fail 
when reading these files.  Only affected PPC version. 

Version 10.70 (04/05/12) 

1. Mac and PC:  Menu item ‘Utilities -> ASCII to Library’ added.  This is the inverse 
of menu ‘Utilities -> Library to ASCII’ and the “columns” option selected.   

2. Mac and PC: Bug fix: The internal check for wavelengths being monotonic (either 
increasing or decreasing) sometimes gave an erroneous message.  It has been 
corrected. 

3. PC:  Improved memory management for the Windows 64 bit version. 

4. Mac and PC: A popup menu allowing multiple levels of interpolation added to the 
load image dialogs for LASF and ASCII Lidar files. 

5. Mac and PC: Increased the maximum number of image cube bands to 3072.  

6. Mac Intel: Bug fix:  The cube file headers (*.hdr) generated by menus 
‘Applications -> Radiance -> Emissivity’ and ‘Utilities -> Library to Cube’ did not 



correctly specify the byte order: should be “little endian”.  The Mac Power PC version 
was correct. 

Version 10.60 (08/15/11) 

1. Mac and PC:  The open file dialog for LASF images has been modified to allow 
more choices in selecting which value of elevation should be rasterized and an option 
to suppress certain types of spikes due to vegetation (see latest HyperCube.pdf 
documentation for details). 

2. Mac and PC:  Added image scale (mtrs/pixel) annotation to menu Functions -> 
Plots -> Profile for images that have a geo reference. 

3. Mac and PC:  Pressing key combination: command 4 on the Mac and Ctrl 4 on the 
PC when the cursor is positioned over an active (front most) image window will 
create one or more text windows containing a listing of pixel values surrounding the 
cursor’s position.  The display values and the underlying pixels (e.g., 16 bit, float) 
values are listed in a 15 by 15 array.  True color images produce list windows for each 
color. 

4. Mac and PC:  The name of the image cube used in menu Classify is now 
concatenated to the classify output image name. 

5. Mac and PC: Bug fix:   Longitudes that were exact multiplies of 6 degrees 
produced an incorrect zone number (off by 1) when displaying UTM coordinates in 
the Info window. 

6. Mac and PC: Bug fix:  Latitudes below the equator are now computed correctly as 
UTM False Northings. 

Version 10.51 (05/25/11) 

1. Mac and PC: Bug fix: Saving contours and class maps as a shape file is now 
compatible with ESRI ArcMap.  Shape files that are geo referenced now include a .prj 
file describing the coordinate type along with the normal .shp, .shx and .dbf files. 

2. Mac and PC: Bug fix: Choosing a new color link image (menu Image -> Convert 
Image -> New Cube Link) for a cube would crash if the link image was a class map.  
Choosing this type of selection should not have been available. 

3. PC: Bug fix: Crash after Reset button (menu Image -> Filter -> Static 5x5) when 
filtering a shaded relief (menu Application -> Shaded Relief) of an image. 



4. Mac and PC: Bug fix: Spectral library parsing bug.  The raw spectral format 
(simple wavelength:value pairs) was not always recognized when loading a spectral 
signature from the library. 

5. Mac and PC: Bug fix: Clicking within a spectra plot did not go to the correct 
wavelength:value pairs in the scroll list if the spectra wavelengths were in the order: 
longer wavelength to shorter wavelength. 

6. Mac and PC: Bug fix: Using the Sobel filter (menu Image -> Filter -> Static 5x5) 
on certain floating data images produced a totally black result. 

7. Mac and PC: Number of spectra values per signature increased from 1024 to 3072. 

8. PC: Bug fix: Menu Functions -> Classify of a cube against a library (File:Lib) with 
“Enable dynamic display” checked in the Classify Options produced an updated label 
with trails.  Not an original bug -  was introduced in October ’09. 

Version 10.4 (01/20/11) 

1. Mac and PC: Bug fix: Loading NITF images containing hyperspectral data had 
several problems.  Those have been remedied. 

2. Mac and PC: Bug fix: Saving a contour (Menu -> Applications -> Contour) as a 
shape file gave an incorrect error message and failed to save.  Now corrected. 

3. Mac: Bug fix: Menu Image -> Filter -> Dynamic 5x5 did not operate if the image 
was float or 16 bit.  Static 5x5 and PC version okay. 

4. Mac and PC: Bug fix: Loading PNG files which contained an alpha channel did not 
always display correctly. 

5. Mac and PC: Added two new functions to menu Functions -> Image Arithmetic: 
dft_phase(s1) and dft_nterms(s1,n).   The first one displays the Fourier frequency 
phase spectrum of image s1 and the second function computes the Fourier transform 
of image s1, keeps the n percent of the greatest magnitude coefficients and inverts the 
result back to an image.  The later demonstrates how few coefficients are needed to 
maintain a visually acceptable image.  Image Arithmetic function ps(s1), which 
displays the Fourier frequency power spectrum, has been renamed to dft_power(s1) 
for consistency.  However, the old name is also valid. 

Version 10.31 (08/27/10) 



1. PC: Bug fix:  Menu Functions -> Classify, Method: Euclidean Distance did not 
correctly classify or produce correct ROC plots.  This was a recently introduced bug 
and only affected the PC versions. 

Version 10.3 (08/25/10) 

1. Mac and PC: Menu Functions -> Fourier has been modified to permit interactive 
dynamic filtering (see Dynamic in Fourier Options).  When enabled, changing the 
sliders will continuously update the output window with new results. 

2. Mac and PC: Menu Image -> Filter -> Static has additional pre-stored kernels: 
Sobel x, y and combined xy gradients for 5x5 and 3x3 subset convolutions. 

3. Mac and PC: Menu Image -> Filter -> Dynamic has been changed from an 
interactive 3x3 kernel to an interactive 5x5 kernel that progresses from a low pass 
Gaussian to a high pass Laplacian  convolution. 

Version 10.2 (08/01/10) 

1. Mac and PC: Added Load/Save PNG (Portable Network Graphics) files.  Eight and 
sixteen bit gray and color component are recognized.  This includes files containing a 
palette and those with an alpha channel (transparency)  although the alpha byte is 
ignored.  HyperCube.pdf contains the details. 

2. Mac and PC: Bug fix: The menu Functions -> Arithmetic, function gray(), did not 
always return a gray scale image when generating a sequence. 

Version 10.1.1 (05/01/10) 

1. Mac and PC: Bug fix: The recently added menu Utilities -> ASCII LIDAR to 
LASF did not process negative Z values correctly.  Native LASF (non ASCII) files 
are not affected. 

2. Mac and PC: Bug fix: ASCII LIDAR files with variable length records (e.g., 
differing decimal precision) sometimes caused a crash. 

Version 10.1 (04/23/10) 

1. Mac and PC: New item: Menu Utilities -> ASCII LIDAR to LASF directly 
converts an ASCII file representing LIDAR data (e.g., X Y Z Intensity) into an LASF 
file.  Allows several options (see HyperCube.pdf documentation). 

2. Mac and PC: A code change was made in Save As… LASF which has the effect of 
causing previously saved images in LASF to now be loaded flipped top to bottom.  



This change only affects images that did not have any UTM or Geographic reference.  
This was done to be consistent with having the top of an image representing a 
maximum in Y when there is no coordinate reference. 

3. Mac and PC: A better mathematical method when converting between UTM and 
Geographic coordinate systems that are defined by RPCs (Rational Polynomial 
Coefficients);  Implemented in menu Edit -> Options -> Geo Coords <--> UTM 
Coords. 

Version 10.0.1 (01/14/10) 

1. Mac PPC: Bug fix: Menu Image -> Gray Mapping didn’t apply the gray map 
results to the image.  This was a recently introduced bug.  (Only applicable to the Mac 
PPC version, Intel Mac and PC not affected). 

2. PC: Bug fix: Certain Windows 7 video cards don’t support 4 and 8 bit cursor depths 
correctly.  This resulted in a missing cursor (cross) when the mouse was moved over 
an image window.  This has been fixed in both PC versions. 

Version 10.0 (12/07/09) 

1. Mac and PC: Menu Functions -> Mosaic -> Points can now mosaic entire image 
cubes (i.e., every band).  All reference to External Control has been removed since 
this is accomplished via menu Functions -> Mosaic -> References. 

2. PC: Bug fix: The flicker that sometimes occurs when the cursor is placed over a 
class map region of a cube face has been eliminated. 

3. Mac and PC: Bug fix: Choosing ‘Countable’ as the Classification Match Criteria in 
Classify Options produced the ‘N’ worst, not the ‘N’ best, matches if ‘Mahalanobis 
distance’ was the chosen classify Method.  Also, corrects Mahalanobis distance when 
used in generating ROC curves in Classify. 

4. Mac and PC: Images may be saved in LAS file format (previously, only Opened). 

5. Mac and PC: Menu Utilities -> Merge LAS Files has been added.  Two or more 
LAS files within the same UTM zone can be merged into a new single LAS file. 

6. Mac and PC: Menu File -> Load Selection only loads the minimum bounding 
rectangle (excludes zero region) when the overview represents a LAS file. 

7. PC: A five times speedup when loading ASCII Lidar files.  Mac version did not 
have this problem. 



8. PC: Bug fix: Menu Image -> Attach -> Data (class map) often chose wrong image 
type resulting in confusing error messages. 

9. Mac and PC: Menu Image -> Attach -> Remove Data can now remove any 16 or 32 
bit data attached to a cube image.  Previously, limited to single images. 

10. Mac and PC: Menu Utilities -> Concatenate -> Cubes can join two in-memory 
image cubes into one side by side image cube.  Previously, only individual bands 
could be joined. 

 


