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Quick Start 
 
The various sample data files after expansion (use Zip): 
 
Cc     Color wheel (8 bit BSQ, 440 pixels by 290 lines by 3 bands), 373 KB (binary). 
 
Cc.hdr    Its header file (ASCII). 
 
Cc.wav   and wavelength file (ASCII). 
 
URBAN HYDICE sensor imagery (16 bit BIL, 307 pixels by 307 lines by 210 bands), 

40 MB (binary). 
 
URBAN.hdr   The corresponding HyperCube header (ASCII). 
 
URBAN.wav  The corresponding wavelength file (ASCII). 
 
TERRAIN HYDICE sensor imagery (16 bit BIL, 307 pixels by 500 lines by 210 bands), 

64 MB (binary). 
 
TERRAIN.hdr The corresponding HyperCube header (ASCII). 
 
TERRAIN.wav The corresponding wavelength file (ASCII). 
 
DTED    Digital terrain elevation file (binary, 572 KB). 
 
DTED.hdr  Its corresponding header (ASCII). 
 
Lidar.las   Lidar X, Y, Z and Intensity data in LASF 1.2 format. (139 MB) 
 
Lidar 1.3.las  Lidar X, Y, Z, Intensity and waveform data in LASF 1.3 format. (210 MB) 
 
Library.zip Spectral library (49 signature files and 1 library list file, all in ASCII, 300 KB). 
 
Duncan Knob.sdf Lidar full wave form SDF file (60 MB). 
 
Duncan Knob.idx Required index file for Duncan Knob.sdf (4.5 MB). 
 
sbet_mission 1.out Smoothed Best Estimate of Trajectory file.  Needed for Duncan Knob.sdf (98 MB). 
 
Immediate scenarios that you can try (it’s helpful to also have the documentation handy): 
 
The color wheel (Cc): 
 
1. Double click HyperCube to launch it. 
 
2. If Mac then choose menu item File > Open As..., if Windows choose File > Open... 
    A standard Open File dialog will appear. 
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3. Select Multiband as the file type from the popup menu. 
 
4. Traverse the directories to find Cc and press Open. 
 A dialog window will appear showing the contents of the header (hdr) file. 
 
5. Press the Load button (no changes are needed) and the cube image will be displayed. 
 
6. Select menu item Image > Cube Color Composite > Specific Wavelengths and a color image of the 3 

bands of the cube will be generated (this isn't necessary but gives you a nice color image 
to select points from).  If this menu item is dimmed, then click once on the image to activate it. 

 
7. Position the cursor within the large yellow square on the color image and hold down the shift key 

while clicking the left mouse button.  A small red crosshair will be set with the number “1” near it. 
 
8. Select menu Functions > Classify...  A new dialog will appear with a single point shown within a list and a 

magnified area displaying the selected point. 
 
9. Press the Classify button in the dialog.  A new image will be generated displaying the color regions 
 matching the selected point within a tolerance.  Move the cursor over this region and a label will 
 dynamically appear with the number “1” in it. 
 
10. You have just performed a single point classify using the Vector Angle algorithm with a tolerance 

of .08 radians. 
 
11. Select several more points on the true color image or the cube itself  by shift clicking the mouse. 
 The additional points  will be added to the classify dialog list.  Press Classify and this time 
 a multiple class map will be generated yielding the class as the cursor is moved over it. 
 
12. Select File > Close All from the main menu to continue with the other data sets. 
 
The urban hyperspectral scene file (URBAN): 
 
1. These steps, using HYDICE imagery, are a bit more involved than those used in file Cc. 
 
2. If Mac then choose menu item File > Open As..., if Windows choose File > Open... 
    A standard Open File dialog will appear. 
 
3. Select Multiband as the file type from the popup menu. 
 
4. Traverse the directories to find URBAN and press Open. 
 A dialog window will appear showing the contents of the header (hdr) file. 
 
5. Press the Load button (no changes are needed) and the cube image starting at band 60 will be displayed. 
 
6. Select menu item Image > Cube Color Composite > Definitions... 
 
7. Check Use histogram equalization in the resulting dialog. 
 
8. Click Okay. 
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9. Select menu item Image > Cube Color Composite > Specific Wavelengths to form a color composite 

image from the cube image bands. 
 
10. Select main menu item Windows > Show Info and position it so it's not overlapping the images. 
 
11. Reactivate the color composite image and move the cursor over the color image and while observing the x 

and y coordinates in the Info window shift click each of 3 points at coords [135,37], [87,134] and [213,124].  
Exact positioning is not critical but these should be a road, a grassy area and a roof top respectively.  You 
can clear all points and try again by selecting menu item Edit > Clear. 

 
12. Select menu Functions > Plot > Spectra (Selected Points).  This will display a spectral plot 

of each point.  Position it as necessary and reactivate the color composite image. 
 
13. Select menu Functions > Classify...  A dialog will appear with the 3 points shown within a list 

and a magnified area within the dialog displaying a highlighted point. 
 
14. Press the Classify button in the dialog.  A class map will be generated displaying 3 color regions 

matching the 3 selection points.  Move the cursor over each region and a label will dynamically appear with 
a number matching the selection point. 

 
15. You have just performed a 3 point classify using the Vector Angle algorithm with a tolerance 

of .08 radians. 
 

The next continuing steps show how to classify the 3 selected image points against a library. 
 
16. On the Classify dialog press Load Lib... button and open the folder containing the library signatures.  All of 

the signatures and the Alib file must reside within the same folder. 
 
17. Select file Alib, it will be the first line shown in the entire list, and Open it.  The library will 
 be processed (a progress indicator will be shown) after a few seconds. 
 
18. Click on the Library radio button in the classify dialog (it's within the Search Domain outline box at the 

upper right).  Leave the Signature outline box set at the File button. 
 
19. Press the Classify button.  Three new windows will appear, each representing the 4 closest library 

signatures that match the selected image points.  Double click a line within any of the 3 windows and that 
signature will be displayed in a graph type window.  Now, click the graph portion and drag it over the top of 
the main signature plot that was produced in step 12 and release the mouse.  The signature will be added to 
the main plot window.  It will be superimposed in black to show you how well it matched a selection point.  
Clicking the colored buttons on the right margin of the main plot window toggles a specific plot on and off. 
By using the Options... button in the Classify dialog you can change the number of closest matches 
(defaulted to 4). 

 
20. You have now classified a spectral image against a library. 
 
The next steps will perform the inverse of the above, i.e., classify a library signature against the image. 
 
21. Scroll the Alib window to signature 41 (Trees 1).  Double click it to select it. 
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22. On the Classify dialog window select the Library button in the Signature outline box and 

the File button in the Search Domain outline box so that you are classifying a library signature against the 
image. 

 
23. Press the Classify button and shortly a single class map will appear.  Compare it with the color composite 

image of the same area. 
 
24. Move the cursor over the class map area (red) and the matching library name will appear. 
 
25. You may select additional signatures in the Alib window and produce a multiple signature 
 class map.  Double clicking a chosen signature in the list deselects it. 
 
This group dynamically searches the library for the best matches as a function of cursor position. 
 
26. Assuming the state of the HyperCube program is unchanged to this point, select File as the 
 Signature and Library as the Search Domain in the Classify dialog. 
 
27. Press the Options... button on the Classify dialog.  A lot of stuff will appear. Check Enable dynamic 

display in File:Lib searches.  Press Okay to exit the options dialog. 
 
28. Press the Classify button.  Then, as you move the cursor over the Urban cube image window 
 or its corresponding color composite window the 4 closest library names will be listed. 
 
29. As an added visual feature, choose Functions > Plot > Spectra (Dynamic).  A plot window 
 will appear showing the image and the matching library signatures as the cursor is moved. 
 
30. Try all of the above using the TERRAIN hyperspectral image data set. 
 
31. Menu Windows -> Show Band -> List will display the listing of all of the cube bands indicate 
 which are enable or disabled.  Only enabled bands are used in a classification.  Double  clicking 
 the right hand column toggles between the two.  This takes immediate effect so you can redo a 
 classification to see the result. 
 
The digital image data (DTED): 
 
1. Choose menu item File > Close All and answer "no" to any save dialogs. 
 
2. Choose File > Open As... and select Raw as the type of file and load image DTED. 
 
3. Click the Load button in the header dialog.  A 512 by 512 representation of DTED will appear. 
 
4. Choose menu item Applications > Shaded Relief... and check Anaglyph, then Okay. 
 
5. Two images will be generated.  The first is the shaded relief and represents a "Sun" angle of 45 degrees 

coming from the upper left.  The second is an anaglyphic stereo of the data that may be viewed in 3D with 
typical red/cyan glasses. 
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The X,Y,Z,Intensity point cloud data (Lidar.las) 
 
1. Choose menu item File > Close All and answer “no” to any save dialogs. 
 
2. Choose menu File > Open As... and load image Lidar.las. Displays Load LASF Data dialog. 
 
3. Select Load Overview from the dialog.  Displays scaled elevation and intensity images. 
 
4. Draw a small selection rectangle in the center of the intensity image. 
 
5. Choose menu File > Load Selection.  This re-displays the Load LASF Data dialog. 
 This time check “Load data as a point cloud and enable viewer”.  Select Load Select. 
 
6. The Overview and View windows and Point Cloud Viewer dialog will be displayed. 
 The Overview contains a default selection rectangle of the data projected on the View window. 
 
7. Type 60 into the omega edit field and 45 into the kappa edit field followed by enter/return. 
 
8. The View window now shows this projection. 
 
9. Try pressing the interactive spin controls to see their effect. 
 
10. Resize the selection rectangle shown on the Overview and enter new values or press the controls. 
 
11. Press the Point Cloud Viewer Options… button and try the various options. 
 In particular, select Display anaglyph 3D view.  This opens another view window that displays 
 the current point cloud in 3D using red/cyan glasses.  Also,  select Limit view... and enter "2" in 
 the return number.  The view will  now only show 2nd return cloud points.  Colorize... mixes color 
 with the intensity or elevation points. 
 
13. The Reset button is used to return everything to the appearance shown in Step 6. above. 
  
 
The X,Y,Z,Intensity and waveform data (Lidar 1.3.las) 
 
1. Open the file as described in the previous Lidar section. 
 
2. Select Form image of n'th waveform sample and enter 19 in the edit box. 
 After a few seconds an image composed of just the 19'th sample will be displayed 
 behind the primary intensity and  elevation images.  Any waveform sample within the 
 bracketed limits may be displayed.  It will be geo referenced. 
 
3. Select Save waveforms as a geo ref cube.  This will take a while and when complete all of the 
 waveforms will be extracted and placed in a multiband file representing a cube matching the size of the 
 intensity and elevations  images and having a depth equal to the maximum number of samples in the 
 waveforms.  It too, will be geo referenced.  This cube can be exploited as if it represents 
 spectral signatures  by using Classify described above. 
 



 6 

The Riegl (www.riegl.com) Lidar full wave form data (Duncan Knob.sdf) 
 
1. This example is only applicable to the Windows version of HyperCube. 
 
2. Place a sdfifc32.dll or sdfifc64.dll in the same folder as the corresponding HyperCube executable. 
 If not in same folder then you’ll be asked to browse for the dll. 
 Each dll is included in the HyperCube.zip download. 
 
3. Place Duncan Knob.idx and sbet_Mission 1.out in the same folder as the Duncan Knob.sdf file. 
 These files are included in the Duncan Knob.zip download. 
 
4. Choose menu item File > Close All and answer “no” to any save dialogs. 
 
5. Choose menu File > Open As... and select file type SDF in the open file dialog. 
 Choose file Duncan Knob.sdf.  The program will immediately start parsing the file and display 
 a progress window.  This takes a few minutes.  When complete, a very busy dialog will appear. 
 
6. For this data set: enter 220 in '# of scan lines:' edit box of the Parameters section 
 and enter 1 in the 'Process channel #' edit box. 
 In the Outputs section select: Elevation image, Interpolation, FWF cube and Geo cube check boxes. 
 Also, check the LAS file box.  The Intensity image check box should already be selected. 
 Leave all other  dialog values as they are. 
 Click the Process button.  After several minutes the Intensity and Elevation images will appear. 
 The LAS file and both cube image files are  written to disk. 
 
7. Choose menu File > Open As... and select file type Multiband in the open file dialog. 
 Choose file * geo cube .  The resulting image cube window will appear to be black. 
 Scroll through the bands and the image will start to appear and reach maximum brightness around band 18. 
 With the window  selected, chose menu  Function -> Plot -> Spectra (Dynamic).  When the 
 plot window appears check Scale and uncheck [0,1].  Move the cursor over the geo cube window. 
 The plot will dynamically display the full wave form return signature at each position. 
 The last band (right side of plot) is not part of the signature, it contains meta data. 
  
8. Although the geo cube is not spectral you can still perform any type of classification on it using 
 the steps described in The urban hyperspectral scene file section above.   Be sure to disable 
 the last band using step #31 in that section to prevent it from being used in a classification. 
 
9. The three LAS outputs will save the results in LASF 1.2, LASF 1.3 (internal waveform) and 
 LASF 1.3 (external waveform) respectively.  These act as an SDF to LASF converter. 
 
10. The LAS files generated in step 6 can be viewed using the steps outlined in section 
 X,Y,Z,Intensity point cloud data in the previous example. 
 
 See the HyperCube.pdf for a description of SDF and LAS file processing. 
 
 
These steps represent a tiny fraction of the capabilities of HyperCube.  The documentation describes each 
function in detail plus numerous visual examples. 
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For comments and suggestions contact: 
 
 Robert S. Pazak 

(703) 428 7871 
email: robert.s.pazak@usace.army.mil 

 U.S. Army Engineer Research & Development Center - Geospatial Research Laboratory 
 Bldg. 2592 
 7701 Telegraph Rd. 
 Alexandria, VA 22315-3864 
 
 
 
 
 


